22:03:03 <gregdek> #startmeeting Eutester meeting, 1 December 2011
22:03:03 <eucabot|test> Meeting started Thu Dec 1 22:03:03 2011 UTC. The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:03:03 <eucabot|test> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:03:05 <gholms> I just poked him. :)
22:03:11 <viglesias> hey guys sorry
22:03:12 <gregdek> Timing! :)
22:03:15 <gregdek> No worries. Perfect.
22:03:19 * gregdek rummages up schedule.
22:03:29 <gregdek> #chair gholms viglesias dak419
22:03:29 <eucabot|test> Current chairs: dak419 gholms gregdek viglesias
22:03:43 <gholms> #topic Roll call
22:04:10 * gregdek is here
22:04:22 * gholms lurks
22:04:45 <dak419> *peep*
22:04:46 <gholms> Oi!
22:04:46 <viglesias> * 50 Lurk points*
22:04:52 <dak419> vic!
22:05:07 <gregdek> OK. I think that's it. :)
22:05:22 <gregdek> #topic Open items
22:05:32 <gregdek> From last meeting on 11/17:
22:05:32 <gregdek> http://meetbot.eucalyptus.com/meeting-logs/eucalyptus/2011-11-17/eucalyptus.2011-11-17-22.10.html
22:05:49 <gregdek> Looks like I have two items, and I don't remember if I handled them. :)
22:06:07 <gregdek> * Change project name to Eutester
22:06:10 * gregdek looks.
22:07:02 <gregdek> So I changed the *name*, but not the *url*.
22:07:06 <gregdek> Because I was lazy.
22:07:37 <gregdek> And I also didn't do #2: add the meeting minutes.
22:07:43 <gregdek> So boo me on those counts.
22:07:47 * gregdek adds tickets now.
22:07:59 <viglesias> okay i can boo myself for not doing #2
22:08:10 <gregdek> Well, it was my TODO, right?
22:08:24 <gregdek> So saith the minutes.
22:08:26 <viglesias> excuse me #3, and i didnt _finish_ it
22:08:32 <gregdek> Aaaaaaah.
22:08:42 <gregdek> The first sample test case?
22:08:44 <viglesias> right
22:09:01 <viglesias> man my numbers are of
22:09:02 <viglesias> f
22:09:13 <viglesias> i didnt finish #2 but did finish #3
22:09:16 <viglesias> there
22:10:04 <gregdek> OK :)
22:10:31 * gregdek looks at issues.
22:10:34 <gregdek> Tickets.
22:10:55 <gregdek> None. OK, I'll make these issues so we can actually track them.
22:11:13 <gregdek> #action gregdek to make tickets of all unfinished items from 11/17 minutes
22:11:28 <gregdek> Simple enough.
22:11:43 <gregdek> viglesias: any particular blockers for that first test case?
22:12:17 <viglesias> none, and now that im looking looks like i did actually complete it
22:12:18 <dak419> btw, we also have eustore test case now (checked in)
22:12:29 <gregdek> Woo!
22:12:31 <viglesias> yep
22:12:35 <viglesias> https://github.com/eucalyptus/eutester/blob/master/tests/test.py
22:12:57 <dak419> couple weeks old, but my goals in SBA next week are to work with Vic on getting that into an actual QA test, and work on Silvereye
22:13:11 <viglesias> dak419: ack
22:13:14 <dak419> cool, vic?
22:13:49 <viglesias> So, now then we just need people to help me fill out the API
22:14:07 <gregdek> Which means articulating what you need help with. :)
22:14:14 <gregdek> Is there a quick way to grep for all the stubs?
22:14:21 <viglesias> its all in one file
22:14:26 <gregdek> Actually, one sec...
22:14:31 <gregdek> #topic Open Floor
22:14:34 <viglesias> https://github.com/eucalyptus/eutester/blob/master/eucaops/eucaops_api.py
22:15:19 <gregdek> Oh, solid.
22:16:31 <gregdek> It seems to me that we're going to need a well-articulated statement of what this is, and how it's intended to work.
22:16:43 * gholms desperately needs to read the API :\
22:16:48 <gregdek> To give people some grounding about why they'd even want to bother with this.
22:16:53 <viglesias> gregdek: agreed
22:17:06 <gregdek> Well, maybe the README is pretty good, actually.
22:17:11 * gregdek looks.
22:17:20 <viglesias> https://github.com/eucalyptus/eutester/blob/master/README.md
22:17:23 <viglesias> not great
22:17:38 <viglesias> but thats the place
22:18:17 <viglesias> #action viglesias to beef up README with more explanation about goals, purpose, and guidelines for contribution
22:18:25 <gregdek> Yep.
22:19:19 <gregdek> All right.
22:19:39 <gregdek> I think that's the main thing to do next, and I assume, viglesias, that you will simply continue to hack away as you have time.
22:19:45 <gregdek> More or less?
22:19:48 <viglesias> Truth
22:19:52 <gregdek> Okey doke.
22:20:02 <gregdek> Any other questions / issues?
22:20:22 <viglesias> im good with it
22:20:24 <gregdek> If not, I think we've got a pretty quick close.
22:20:31 <gregdek> Concluding in 3..
22:20:34 <gregdek> 2...
22:20:37 <gregdek> 1...
22:20:40 <gregdek> 1/2...
22:20:43 <gregdek> #endmeeting