19:03:30 <gregdek> #startmeeting Images Meeting, 16 December 2011
19:03:30 <eucabot|test> Meeting started Fri Dec 16 19:03:30 2011 UTC. The chair is gregdek. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:03:30 <eucabot|test> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:36 <gregdek> #meetingname images
19:03:36 <eucabot|test> The meeting name has been set to 'images'
19:03:40 <gregdek> Speak of the devil. :)
19:03:44 <gregdek> #topic roll call
19:03:45 * gregdek is here
19:04:04 <hspencer> coo
19:04:22 <hspencer> so lemme bring up past meeting notes
19:04:27 <hspencer> so we can handle old biz
19:04:36 <dak419> here.
19:04:51 * gregdek follows hspencer's lead.
19:05:27 <gregdek> #chair hspencer
19:05:27 <eucabot|test> Current chairs: gregdek hspencer
19:06:11 <hspencer> k, got the list
19:06:15 <hspencer> we ready to do this
19:06:17 <hspencer> ?
19:06:36 <hspencer> ready to start?
19:06:52 <obino> can't wait!!
19:06:55 <hspencer> #topic Old Business
19:07:24 <hspencer> I created RT tickets for Starter EMI page and for renaming URLs for Image Creator Guides
19:07:34 <hspencer> the renaming has been done
19:07:42 <hspencer> sorry
19:08:08 <gregdek> Sweet!
19:08:23 <hspencer> #info Renaming URLs => has been done. In staging open.euca server. Waiting till we are ready to publish Starter EMI page
19:09:03 <gregdek> What else?
19:09:09 <hspencer> #info Publish Starter EMI page => working with G to get the final set of images.
19:09:26 <gregdek> hspencer: are you going through past meeting notes, or tickets, or both?
19:09:30 <obino> when is the target date for publishing?
19:09:46 <hspencer> going through past meeting notes
19:09:50 <gregdek> ok.
19:10:11 <hspencer> unless i am really on it, i won't include ticket information too
19:10:21 <hspencer> i will just use the meeting notes as the driving force
19:10:39 <gregdek> ok.
19:11:04 <hspencer> publish date
19:11:12 <hspencer> hasn't been set cause we keep moving back due to stuff
19:11:20 <hspencer> i would like to have it published by next week
19:11:22 <hspencer> before Wed.
19:11:35 <hspencer> if not, can do it by the end of next week
19:11:48 <obino> sounds good: I will have them done this weekend
19:11:51 <hspencer> cool
19:12:20 <hspencer> #info Publish Starter EMI page => end of next week - Dec. 23
19:12:56 <obino> christmas gift :)
19:12:57 <hspencer> #info review of Ian's python script => didn't happen yet. Will do it this weekend
19:13:55 <hspencer> #info load balanced environment for emis.eucalyptus.com => talked to Ian about it. Decided to see what the load is, then design LB environment later...beginning of next year maybe
19:14:34 <hspencer> #info catalog.json sync with dak419 => hasn't been done yet; will take care of that today
19:14:53 <obino> don't we need the file names for that?
19:14:53 <hspencer> gregdek, did you create eustore project and hand keys to dak419 ?
19:14:58 <hspencer> already have it
19:15:02 <gregdek> I think I did, one sec.
19:15:03 <hspencer> catalog.json
19:15:09 <hspencer> its in a bucket
19:15:09 <dak419> btw, hspencer, if you can get me the emi.id files from all starter images, I'd be happy to generate the catalog.json
19:15:11 <hspencer> on walrus
19:15:16 <gregdek> Yup. https://projects.eucalyptus.com/redmine/projects/eustore
19:15:23 <hspencer> yep, thats what we gotta do dak419
19:15:29 <hspencer> gregdek, cool
19:15:45 <dak419> I haven't done anything with the eustore project site. sorry
19:15:46 <gregdek> dak419: the Eustore project is now yours to drive. ;)
19:15:55 <hspencer> #info gregdek creating eustore project and handing keys to dak419 => done
19:15:59 <gregdek> Sounds like someone needs an #action. ;)
19:16:29 <hspencer> #action dak419 will work on eustore project site and give us update
19:16:37 <hspencer> :)
19:17:06 <hspencer> gregdek, did you file ticket for ticket integration of projects with RT?
19:17:16 * gregdek looks.
19:17:41 <gregdek> Not under images project...
19:18:11 <gregdek> ...and not under infrastructure.
19:18:19 <hspencer> yea, i think you didn't put one in RT
19:18:21 <gregdek> And I'm not sure if I filed this as an RT ticket or not, heh.
19:18:24 <hspencer> nah
19:18:27 <hspencer> just checked
19:18:27 <hspencer> :)
19:18:33 <hspencer> isn't under helpdesk queue
19:18:36 <hspencer> you failed
19:18:37 <gregdek> OK. What Rt queue does this go in?
19:18:37 <hspencer> :-D
19:18:41 <gregdek> helpdesk?
19:18:45 <hspencer> helpdesk@support.eucalpytus.com
19:18:47 <hspencer> ya
19:18:48 <gregdek> Gimme 5 min.
19:19:09 <hspencer> k, i will go ahead an put that you did and we will confirm next meeting
19:19:33 <hspencer> #info gregdek filed ticket for integration of ticketing with projects and RT
19:19:58 <hspencer> #action confirm gregdek created ticket for integration of ticketing systems with projects and RT
19:21:16 <hspencer> k, old business done
19:21:19 <hspencer> any questions?
19:21:35 <gregdek> RT ticket filed.
19:21:36 <gregdek> .win 18
19:21:40 <gregdek> doh
19:22:26 <hspencer> nice
19:22:33 <hspencer> .rt 5208
19:22:42 <hspencer> hmmm, didnt' work
19:22:48 <obino> lol eucabot out for lunch?
19:22:52 <hspencer> gotta talk to gholms about it
19:23:00 <dak419> (btw, added stuff to eustore project wiki)
19:23:24 <hspencer> #info dak419 added information to eustore projects page
19:24:16 <dak419> Q: are we using the redmine issue trackers on these projects?
19:24:19 <hspencer> #info gregdek created RT ticket 5208 ( https://support.eucalyptus.com/Ticket/Display.html?id=5208) about integration of project.eucalyptus.com queues with RT queues
19:24:32 <hspencer> dak419, think we shoudl
19:24:34 <hspencer> should
19:24:47 <gregdek> Optional, I'd say. You need some outward facing mechanism, though.
19:24:52 <hspencer> yep
19:24:55 <hspencer> i agree
19:24:58 <obino> .proj 68
19:24:59 <eucabot|test> obino: Issue 68 (New): HOWTO for running a project - https://projects.eucalyptus.com/issues/68
19:25:04 <hspencer> ?
19:25:05 <gregdek> If it's tracking meeting notes from week to week, fine. If it's a wiki page, fine. But you must have *something*.
19:25:06 <obino> nope eucabot is alive
19:25:11 <hspencer> how the hell did that work?
19:25:14 <gregdek> And it must be *externally accessible*.
19:25:16 <hspencer> .rt 5208
19:25:26 <gregdek> This bot must not understand rt.
19:25:35 <obino> .lp 1234
19:25:36 <hspencer> bastard bot
19:25:39 <eucabot|test> obino: Bug #1234 in Launchpad itself: “Gina is an unmaintainable mess of command line options, environment variables and shell scripts” - https://bugs.launchpad.net/bugs/1234
19:25:42 <dak419> *reads that howto*
19:25:44 <cpt_yesterday> I don't believe we want external eucabot looking at RT currently
19:26:00 <gregdek> Yep.
19:26:06 <gregdek> Agreed with cpt_yesterday.
19:26:15 <cpt_yesterday> If there was a way to limit who could use what then it might work but I don't believe that is built in
19:26:28 <hspencer> ah, figure out which queues it can access
19:26:29 <hspencer> i see
19:26:45 <hspencer> k, so anything else on old business?
19:26:56 <obino> which means we should have the real tix in redmine
19:27:00 <obino> and a link from rt to them
19:27:03 <obino> :)
19:27:18 <hspencer> if not, gonna close it down and start up new business
19:27:21 <gregdek> Which happens to be the ticket I was just asked to file. IMAGINE THAT!
19:27:23 <hspencer> is it a go?
19:27:33 <gregdek> nothing more on lodbiz here
19:27:34 <gregdek> oldbiz
19:27:37 <hspencer> l
19:27:38 <hspencer> k
19:27:46 <hspencer> #topic New Business
19:28:06 <hspencer> gregdek, when is a good time for new meeting time?
19:28:27 <gregdek> hspencer: I haven't done the whenisgood thing, my bad. Need to do that today.
19:28:29 <obino> who couldn't make it before?
19:28:38 <obino> there is a fedora meeting at this time
19:28:39 <gregdek> Because someone said "bad time".
19:28:43 <hspencer> yea
19:28:46 <hspencer> it was our group
19:28:50 <obino> and gholms and I are trying to attend
19:28:52 <gregdek> So we need to do a whenisgood.
19:28:58 <gregdek> Maybe even change it from Fridays.
19:29:06 <hspencer> 9 AM on Friday's won't work
19:29:13 <hspencer> tech services meeting
19:29:14 <gregdek> That's on me.
19:29:24 <hspencer> what about 10 AM?
19:29:24 <gregdek> #action gregdek will send out whenisgood to images mailing list.
19:29:31 <hspencer> k
19:29:32 <gregdek> We are all on the images mailing list, right?
19:29:37 <hspencer> yep
19:29:38 <hspencer> i am
19:29:44 <gregdek> :)
19:29:59 <gregdek> Not a lot of traffic there yet.
19:30:35 <hspencer> should probably send an email out company wide
19:30:47 <hspencer> about new mailing lists for hte community
19:30:51 <hspencer> what you think?
19:30:59 <gregdek> Not a bad idea to remind folks.
19:31:04 <hspencer> cause new folks don't know about it
19:31:10 <hspencer> wanna do that?
19:31:36 <gregdek> Will do.
19:31:43 <hspencer> #action gregdek will send company wide email about community mailing lists
19:31:45 <hspencer> :)
19:31:48 <gregdek> thx :)
19:31:53 <hspencer> i got your back
19:31:58 <obino> as a reminder http://lists.eucalyptus.com/cgi-bin/mailman/listinfo got the full list
19:32:04 <gregdek> It does indeed.
19:32:14 <gregdek> But people don't think to look at it, so a reminder is nice.
19:32:32 <hspencer> we need to update the Description
19:32:33 <hspencer> of those
19:32:44 <hspencer> someone want to do that before we send that out
19:32:51 <hspencer> need to clean up our kitchen
19:32:54 <hspencer> :)
19:33:10 <gregdek> I can do that also.
19:33:14 <hspencer> k
19:33:18 <gregdek> #action gregdek will clean up description of mailing lists
19:33:22 <hspencer> nice
19:33:27 <hspencer> thats cash money
19:33:52 <hspencer> k, what information do we have on Image GPL compliance?
19:33:59 <hspencer> any updates?
19:34:13 <obino> hspencer: I think that's not the issue
19:34:21 <obino> is the trademarks and copyright
19:34:31 <obino> for example we cannot call Fedora our images
19:34:47 <obino> but the images are licenses compliants
19:34:49 <hspencer> yea, i think we just need to communicate it in some fashion
19:34:52 <gregdek> Two separate issues.
19:35:01 <gregdek> 1. Being compliant with distro trademarks.
19:35:04 <hspencer> that we know about this subject
19:35:09 <gregdek> 2. GPL compliance in hosting code.
19:35:34 <gregdek> Which are we looking to tackle>
19:35:35 <gregdek> ?
19:35:57 <hspencer> have a file that we can reference not only for old folks, but for the new folks
19:36:08 <hspencer> so we don't have to repeat ourselves
19:36:14 <hspencer> and also make sure we are consistent
19:36:32 <obino> gregdek: I'm confused at #2: why are we on the line for GPL?
19:37:15 <gregdek> Just need to ensure that binaries we ship (i.e. images) have source available somewhere, and that we are accurately pointing to it.
19:37:24 * gholms returns to his desk
19:37:38 <hspencer> gregdek, is that for ever distro image we provide or certain ones
19:37:38 <hspencer> ?
19:37:46 <hspencer> this is why i think we need a list or something
19:38:25 <obino> gregdek: but the sources are available through the original distros
19:38:26 <gregdek> hspencer: I'm not sure we even know.
19:38:36 <gholms> obino: Not always.
19:38:39 <gregdek> I think in the last meeting, we floated the idea that:
19:38:51 <gregdek> * We own the problem for images we upload;
19:38:54 <gholms> obino: Fedora drops sources for updates soon after future updates obsolete them.
19:38:58 <hspencer> k, so can i recommend that we come up with a draft document?
19:39:00 <gregdek> * We may be able to put on the images that others upload.
19:39:16 <gregdek> s/put/punt
19:39:21 <gholms> gregdek: +1 if that's legally sound
19:39:28 <gregdek> IANAL.
19:39:32 <gregdek> And we need one.
19:40:01 <gholms> Either way we need to run the plan by counsel. But we need a plan first, and that one sounds good to me.
19:40:15 <hspencer> k
19:40:19 <gregdek> OK. What distros do we host / plan to host?
19:40:20 <hspencer> so action item
19:40:28 <gregdek> Each distro will likely need its own policy.
19:40:36 <obino> gregdek: for host, you mean have images?
19:40:39 <gregdek> Yes.
19:40:50 <obino> so far we'll have debian, centos and ubuntu
19:40:53 <hspencer> we have debian, centos, ubuntu
19:40:57 <hspencer> haven't touched fedora yet
19:41:16 <gregdek> ok. I'll assume Fedora will come along at some point.
19:41:45 <obino> yes, it's mainly a time issue (it needed a full reinstall and to fit in 1GB)
19:42:00 <gregdek> Question:
19:42:20 <gregdek> Do we just host base images, with the assumption that users will yum/apt-get install as needed?
19:42:32 <obino> gholms: are you telling me that fedora is not in compliance with GPL?
19:42:42 <gregdek> obino: Absolutely not.
19:42:55 <gholms> obino: They ship sources and binaries together.
19:43:00 <gregdek> But when they stop hosting the distro, they are no longer required to host the sources.
19:43:07 <obino> gregdek: not so
19:43:13 <obino> what gholms says is good
19:43:42 <gholms> obino: By distributing the sources with the binaries they avoid the need to host sources for two years.
19:43:48 <gregdek> They have source available for older distros. It's just not necessarily downloadable.
19:43:54 <hspencer> k, got it
19:44:07 * gholms shuts up
19:44:16 <obino> gholms: don't, you are right
19:44:22 <gholms> Am I?
19:44:23 <hspencer> alright, so who will be responsible for putting all this info in a document?
19:44:27 <gholms> gregdek knows this better than I.
19:44:34 <gholms> So listen to him, please. :)
19:44:37 <obino> lol
19:44:41 <gregdek> Only moderately. I know board discussions from 3 years back. We need to confirm.
19:44:47 <obino> I think we are saying the same thing
19:44:52 <gregdek> Laregly.
19:44:59 <obino> if we have them online, we'll need to keep them around for few years
19:45:01 <gregdek> But we need certainty, and I'll take the lead on that.
19:45:05 <obino> after the image is gone
19:45:17 <gregdek> #action gregdek will draft policy document for GPL compliance and image hosting
19:45:18 <obino> if we ship with the image we are good
19:45:37 <obino> but my point is: we are not changing the code, so do we need to keep a copy?
19:45:49 <gregdek> No, but we need to be able to point to a copy.
19:45:50 <obino> so far the lawsuit I remember they were about changing something
19:46:14 <obino> gregdek: but that's still a tall order
19:46:24 <hspencer> yea, seems like
19:46:26 <gregdek> Not if we don't change any bits.
19:46:29 <obino> it means we have to make sure we have links to all sources
19:46:32 <obino> and versions
19:46:37 <gregdek> Yep.
19:46:44 <obino> if upstreams deletes it, what do we do?
19:46:48 <gregdek> And if we *do* change bits, the overhead goes *way* up.
19:47:03 <gregdek> We follow the upstream's policy, assuming we're talking distros.
19:47:15 <gregdek> If it's Fedora 8, we figure out how users get Fedora 8 source, and link to that.
19:47:17 <obino> ok, I will let you handle this: I'm actually way confused at this point
19:47:37 <gregdek> There should be a "chain of custody" we can follow.
19:47:59 <gregdek> The less we touch the bits, the safer we are.
19:48:44 <gregdek> So long as we offer, for instance, a strict subset of Fedora and don't add our own packages, I think we're completely covered by both Fedora's copyright policies and Fedora's GPL compliance policies.
19:49:09 <gregdek> But if we add our own packages to the image itself, we need to think more deeply.
19:49:28 <gregdek> Do we currently offer stock debian/ubuntu/centos images, or do we alter them?
19:49:53 <obino> as I mentioned my understanding has always been that without modification to code, we don't need to do anything
19:50:05 <obino> our images are stock versions of the packages
19:50:15 <gregdek> obino: yep. Basically correct.
19:50:16 <obino> we just modified rc.local
19:50:25 <gregdek> We should document those modifications.
19:50:30 <obino> they are
19:50:35 <obino> in the project :)
19:50:37 <gregdek> Then sounds like we're good. :)
19:50:47 <obino> rc.local is published there
19:51:12 <gregdek> OK, gives me enough to go on.
19:51:38 * gholms points to EKIs and ERIs
19:52:09 <gholms> Note that installing foreign kernel modules can count as installing non-$distro software as well.
19:52:44 <gholms> (Just another thing to consider)
19:53:07 <hspencer> k i have a question
19:53:13 <hspencer> if we aren't modifying code
19:54:05 <hspencer> k, lets have a meeting about this because this seems to be a long discussion
19:54:13 <hspencer> a meeting outside of this meeting
19:54:16 <gholms> +1
19:54:21 <gregdek> Lemme draft a document and we can go from there.
19:54:26 <hspencer> or dedicate one of these meetings to talk about it
19:54:33 <hspencer> and announce it
19:54:42 <gregdek> May be a while, but this isn't a super-urgent problem; I suspect we're covered.
19:54:51 <gregdek> But we need to be sure, that's all.
19:55:12 <gholms> I think starting draft would help the discussion a lot whenever it does happen.
19:55:17 <gholms> *a starting draft
19:57:02 <gholms> [A dog barks in the distance]
19:58:12 <hspencer> anything else for new business?
19:58:20 <gregdek> Nothing from me.
19:58:25 <lwade> I hear this meeting is getting exciting
19:58:28 <lwade> aww man, just finished
19:59:25 <gregdek> Shall we adjourn, then?
19:59:33 <dak419> ja
19:59:51 <gholms> Right on time, too. :)
20:00:15 <hspencer> yep
20:00:19 <hspencer> #endmeeting