17:01:37 <woodyrollins> #startmeeting Culture
17:01:37 <eucabot> Meeting started Tue Apr 17 17:01:37 2012 UTC.  The chair is woodyrollins. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:37 <eucabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:01:48 <woodyrollins> #meetingname Culture
17:01:48 <eucabot> The meeting name has been set to 'culture'
17:02:01 <woodyrollins> #topic Roll Call
17:02:14 <obino> o/
17:02:18 <woodyrollins> is anyone impressed with my irc dexterity?
17:02:20 <dfederlein> o/
17:02:26 <obino> lol
17:02:27 <gholms> woodyrollins: Great success!
17:02:28 <lwade> skillz
17:02:42 <dfederlein> nicely done, woodyrollins
17:04:56 <woodyrollins> well, thx for taking the time
17:05:08 <obino> old meeting logs http://meetbot.eucalyptus.com/meeting-logs/eucalyptus-meeting/2012-04-10/culture.2012-04-10-17.02.html
17:05:23 <obino> courtesy of gholms, we have the old logs!
17:05:37 * obino is pulling a  standing ovation for gholms
17:05:53 <dfederlein> nicely done gholms
17:05:57 * gholms finished uploading them not ten seconds before obino said that
17:06:48 <lwade> gj gholms
17:07:22 <woodyrollins> #chair gholms,obinogregdek
17:07:22 <eucabot> Current chairs: gholms obinogregdek woodyrollins
17:07:44 <woodyrollins> #chair gholms obino gregdek
17:07:44 <eucabot> Current chairs: gholms gregdek obino obinogregdek woodyrollins
17:07:47 <woodyrollins> there
17:07:48 <gholms> Heh
17:07:54 <obino> woodyrollins: I love your IRC dexterity
17:08:05 <woodyrollins> mln
17:08:05 <gholms> #unchair obinogregdek
17:08:05 <eucabot> Current chairs: gholms gregdek obino woodyrollins
17:08:27 <woodyrollins> #topic Values
17:08:52 <obino> noirin google doc https://docs.google.com/document/d/12SWSXF5c5_KcEHFxFNlxzyvHgPFRvTV7ZxwEiYM1p9I/edit
17:09:12 <gholms> #link https://docs.google.com/document/d/12SWSXF5c5_KcEHFxFNlxzyvHgPFRvTV7ZxwEiYM1p9I/edit
17:09:22 <woodyrollins> So, we tackled Transparency, Excellence and Approachability.  Now our focus turns to the definitions of Collaboration and Humility.
17:09:36 <obino> and we are writing the agreed one on https://projects.eucalyptus.com/redmine/projects/talent/wiki
17:09:50 <woodyrollins> We open the floor to a discussion on the definition of Collaboration"
17:10:16 <obino> from noirin google doc "--We believe in working together: sharing knowledge, co-operating, and building consensus. We strive to create a community that is welcoming and inclusive."
17:10:59 <woodyrollins> What do we think of adding the word "productive"  welcoming, inclusive and productive
17:11:40 <woodyrollins> mentoring?
17:11:45 <obino> woodyrollins: I think it gets a bit too long with productive
17:11:58 <gholms> Mentoring sounds much more applicable to me.
17:12:01 <dfederlein> I think productive is implied
17:12:09 <dfederlein> agreed via mentoring
17:12:31 <obino> I like mentoring too
17:12:44 <woodyrollins> thoughts on how to slide that in?
17:12:57 <obino> sounds weird though: any english native that can massage it in?
17:14:49 <obino> We believe in working together: sharing knowledge, co-operating, and building consensus. We strive to create a mentoring community that is welcoming and inclusive.
17:14:50 <obino> ?
17:15:00 <woodyrollins> brilliant?from the non-native
17:15:07 <dfederlein> I like that obino
17:15:17 <scotm> Excellent, you non-native you.
17:15:17 <obino> I'm native ... not US native :D
17:15:30 <woodyrollins> more like tribal
17:15:35 <obino> ha!
17:15:45 <obino> #idea We believe in working together: sharing knowledge, co-operating, and building consensus. We strive to create a mentoring community that is welcoming and inclusive.
17:16:02 <woodyrollins> i like
17:16:16 <gholms> I'm not sure what a mentoring community is, but I like the words.
17:16:36 <lwade> mentoring community doesn't quite sound right, imo
17:16:57 <woodyrollins> I think of a community that embraces mentoring as a first principle
17:17:17 <gholms> Could mentoring go in the previous sentence's list instead since it is so similar to the other things there?
17:17:36 <obino> We believe in working together: sharing knowledge, co-operating, mentoring, and building consensus. We strive to create a community that is welcoming and inclusive.
17:17:39 <obino> liek that gholms?
17:17:52 <lwade> yes
17:17:56 <gholms> That sounds much better to me.
17:17:56 <lwade> I think that sounds better
17:18:01 <obino> mentoring is not in the dictionary
17:18:17 <gholms> We should get obino a new dictionary.
17:18:17 <obino> scotm: what are you doing? Sleeping during the meeting? LOL
17:18:25 <obino> dict mentoring
17:18:25 <obino> No definitions found for "mentoring"
17:18:32 <scotm> Just lurking, obino.
17:19:04 <obino> :)
17:19:13 <scotm> mentoring: present participle of men·tor. To advise or train (someone).
17:19:39 <obino> ok, I stand corrected
17:19:58 <obino> and I will need a new dictionary, as per gholms suggestion
17:20:13 <obino> so, second idea is
17:20:21 <obino> #idea We believe in working together: sharing knowledge, co-operating, mentoring, and building consensus. We strive to create a community that is welcoming and inclusive.
17:20:50 <woodyrollins> thoughts?
17:21:11 <obino> I would almost drop co-operating: it seems included in sharing knowledge and building consensus to me
17:21:42 <gholms> It's certainly included in "working together."
17:21:50 <obino> We believe in working together: sharing knowledge, keen on mentoring, and building consensus. We strive to create a community that is welcoming and inclusive.
17:22:03 <gholms> Remove "keen on."
17:22:19 <obino> lol
17:22:19 <obino> ok
17:22:30 <gholms> If you want to add more there you could try "mentoring one another".
17:22:39 <woodyrollins> super keen?
17:22:45 <gholms> :)
17:22:54 * scotm thanks gholms for parallelism.
17:23:48 <obino> #idea We believe in working together: sharing knowledge, mentoring, and building consensus. We strive to create a community that is welcoming and inclusive.
17:24:11 * gregdek reads back and catches up.
17:24:32 <scotm> gotta modify "mentoring" to match the others
17:25:14 <obino> mentor each other?
17:25:15 <gholms> Ooh, the cultured people have arrived!
17:25:17 <obino> mentor new member?
17:25:21 <gholms> "mentor one another"
17:25:32 <gholms> "mentoring one another", rather
17:25:48 * gholms <-- grammar police
17:26:39 <obino> #idea We believe in working together: sharing knowledge, mentoring each other, and building consensus. We strive to create a community that is welcoming and inclusive.
17:26:48 <gregdek> I like the mentoring conversation. I think we legitimately care about it, and for our size, I think we do it quite well.
17:26:52 <gholms> s/each other/one another/
17:27:09 <gholms> (I think)
17:27:22 <gregdek> +1 to "one another"
17:27:28 <gholms> scotm: You're an expert! Am I spouting nonsense?
17:29:39 <gregdek> Is silence == consensus? :)
17:29:59 <lwade> I sense a disturbance in the force.......
17:30:02 <obino> nope you just arrived and we were in awe to listen to you
17:30:29 <obino> #idea We believe in working together: sharing knowledge, mentoring one another, and building consensus. We strive to create a community that is welcoming and inclusive.
17:30:30 <gregdek> Yeah, no.
17:30:40 <gregdek> I love it.
17:30:44 <gregdek> +1.
17:30:45 <obino> ok let's get one: which youguys like
17:30:47 <obino> the last one?
17:31:02 <woodyrollins> Yup, sounds good.
17:31:39 <gholms> s/each other/one another/ and I'll be even happier with it.
17:31:44 <gholms> I like it even without, though
17:31:53 <gregdek> gholms -- he did.
17:32:06 * gholms missed that one
17:32:12 <woodyrollins> Shall we move to "Humility"
17:32:25 <gregdek> Nah, I'm too important for that one.
17:32:27 <obino> from noirin's google doc: --We believe in acknowledging the talents and contributions of all our contributors, and in recognizing the limits of our own abilities and knowledge. We strive to learn from each other, and to ask for help when we need it.
17:32:28 * gregdek is afk.
17:33:06 <gregdek> hey shaon :)
17:33:16 <shaon> hello, sorry for late
17:33:31 <gregdek> Me too.
17:33:37 <gregdek> Sorry for me being late, I mean, lol.
17:34:19 <gregdek> No huge improvements from noirin's original text jump out at me.
17:34:21 <obino> haha
17:34:37 <obino> "contributions of all our contributors" seems a repetition to me
17:34:42 <gholms> The fourth clause makes the second redundant.
17:35:19 <obino> gholms: yo umean  We strive to learn from each other, and to ask for help when we need it.?
17:35:44 <gholms> Yeah, those two obviate the one that talks about limits.
17:36:32 <gholms> "We believe in acknowledging the talents and contributions of all our contributors.  We strive to learn from one another and to ask for help when we need it."
17:36:56 <gregdek> What if we don't think we need it? :)
17:37:00 <gholms> obino's comment about contributions/contributors sort of sticks out to me
17:37:17 <gholms> gregdek: Same as everywhere else: learn it the hard way?
17:37:26 <gregdek> Ditto the contributions/contributors language. Now that it's been pointed out, it's noticeable.
17:38:04 <obino> We believe in acknowledging the talents and contributions, and in recognizing the limits of our own abilities and knowledge. We strive to learn from each other, and to ask for help when we need it.
17:38:08 * gregdek thinks about "accepting help when it's offered and asking for help when it's needed" or something...
17:38:58 <gregdek> obino: I would put it "We believe in acknowledging the talents of all our contributors."
17:39:47 <obino> We believe in acknowledging the talents and the work of all our contributors, and in recognizing the limits of our own abilities and knowledge. We strive to learn from each other, and to ask for help when we need it.
17:39:47 <obino> ?
17:40:18 <gholms> Can we please kill off the second clause there?  It's negative and redundant.
17:40:42 <obino> gholms: I think is part of humility
17:40:50 <obino> no?
17:40:51 <gregdek> Recognizing the limits of our own abilities is too negative?
17:40:58 <gregdek> I think it's kind of the point. :)
17:41:31 * gholms tries to make the second sentence less redundant, then
17:41:39 <gregdek> "Sometimes we suck. When we do, we own it." :)
17:42:37 * gregdek hrms.
17:42:49 <shaon> :P
17:42:58 <obino> #idea We believe in acknowledging the talents and the work of all our contributors, and in recognizing the limits of our own abilities and knowledge. We strive to learn from each other, and to ask for help when we need it.
17:43:14 <obino> shaon: you don't like it?
17:43:40 <shaon> obino: I just laughed at gregdek's last post
17:43:48 <gholms> gregdek: Do open source communities generally care about talents or do they care about accomplishments?
17:43:55 * gholms is thinking merit-based
17:44:13 <gregdek> gholms: they care about not having their patches stepped on because of high-handed NIH behavior.
17:44:23 <dfederlein> agreed, gregdek
17:44:38 <gholms> How can we make this statement echo that sentiment?
17:45:00 <gregdek> They care about being able to argue the merits of their work with people who will engage with them in fair debate that doesn't presume a right answer beforehand.
17:45:19 <obino> NIH?
17:45:23 <gholms> not invented here
17:45:24 <gregdek> "not invented here"
17:45:39 <gholms> See also "eucalyptus"
17:45:42 <gregdek> Ouch. :)
17:45:44 <gregdek> LOL
17:46:00 <gregdek> So maybe this is a point for reflection.
17:46:16 <gregdek> Are we sufficiently modeling this value in such a way that we can legitimately claim it?
17:46:24 <gregdek> Or is it perhaps more aspirational at this point?
17:46:31 * gregdek afk a sec, brb
17:47:44 <gregdek> back, sry
17:47:56 <gregdek> Are we humble?
17:48:00 <gholms> I have yet to see Eucalyptus demonstrate it either inside or outside with respect to code.
17:48:02 <obino> gholms: LOL
17:48:12 <gholms> Not sure about other things
17:48:36 <obino> the LOL was for before
17:48:44 * gholms nods
17:48:51 <gregdek> Well, then.
17:48:54 <obino> I think that large part of our community and us are humble
17:48:58 <gholms> It sounds like a great aspiration, though.
17:49:03 * gregdek nods.
17:49:11 <gholms> obino: But can you honestly say that about Eucalyptus Engineering?
17:49:13 <gregdek> Part of this exercise is to represent what we strive to be.
17:49:14 <gholms> I can't.
17:49:19 <gholms> gregdek: Good point
17:49:30 <gregdek> So maybe we should take this to engineering specifically and have some frank discussions.
17:49:32 <obino> gholms: I believe that most of engineering is shy and not accoustomed to talk to strangers
17:49:35 <obino> I do believe that
17:49:40 <gregdek> obino: I agree, I think.
17:49:41 * gholms agrees with that
17:49:42 <obino> and they simply refuse to engage
17:50:13 <gregdek> There's a difference between arrogance and shyness, but the one can look like the other.
17:50:15 <obino> so I think the value is correct
17:50:27 <woodyrollins> gregdek:  that's true
17:50:31 <obino> and aspiring to it is good
17:50:49 <gregdek> woodyrollins: I've been accused of arrogance my whole life, when sometimes I just can't speak up. :)
17:50:54 <obino> we circulate the minute last week and nobidy coimplained :)
17:51:06 <gregdek> (And sometimes it is arrogance. A lifetime of learning, heh.)
17:51:26 <gregdek> obino: you know as well as I do that doesn't necessarily mean a thing. :)
17:51:31 <woodyrollins> It would be great to engage with Engineering with this single agenda point
17:51:55 <woodyrollins> a discussion of humility
17:51:56 * gregdek nods.
17:52:08 <gregdek> woodyrollins: maybe I could tackle this one.
17:52:17 <woodyrollins> you'r ehired
17:52:24 <obino> lol
17:52:46 <woodyrollins> this is a very important topic, thx gholms
17:52:53 <gregdek> #action gregdek will tell a parable to Euca engineering about humility :)
17:53:47 <gregdek> I think that will be an interesting exchange.
17:54:15 <gholms> Thanks, everyone!
17:54:44 <obino> we are getting clsoe to to the top of the hour
17:54:47 <dfederlein> :)
17:54:52 <obino> was the last idea a sensible attempt?
17:55:07 <obino> or should we shelved it till gregdek comes back from his holy grail mission?
17:55:11 <gholms> I think it could use some wordsmithing, but the idea is sound.
17:55:11 <gregdek> obino: I think maybe we want to reflect a bit more.
17:55:25 <dfederlein> tweaking, but it's a solid premise
17:55:26 <gregdek> I do, anyway.
17:55:28 <gholms> We can find out how realistic it is after gregdek talks some more.
17:55:43 * gholms phrased that poorly
17:55:48 <obino> gregdek: we know you aare a slow thinker and you didn't read last week minutes :)
17:55:53 <dfederlein> LOL
17:55:55 <dfederlein> ouch
17:56:03 <dfederlein> bbiaf, need a sammich
17:56:14 <woodyrollins> i like what we have, we just have to make sure that we "walk the walk and talk the talk"
17:56:24 <shaon> gregdek: may be engineering folk can take classes on eucalyptus-classroom
17:56:37 <shaon> s/folk/folks
17:56:44 <gholms> woodyrollins: +1
17:56:48 <dfederlein> +1 woodyrollins
17:56:48 <shaon> just saying
17:56:57 <gregdek> woodyrollins: +0.9.
17:57:08 <gregdek> I'll give you the extra 0.1 when I'm satisfied we believe it. :)
17:57:09 <dfederlein> lol
17:57:20 <gregdek> shaon: I agree with that.
17:58:30 <shaon> woodyrollins: +1
17:58:49 <woodyrollins> great work folks?
17:59:00 <obino> great discussion
17:59:03 <gregdek> Yep.
17:59:11 <gregdek> We're digging deep. I like it.
17:59:38 <woodyrollins> Yes, this will be a defining discussion.
17:59:50 <woodyrollins> That said, I move to adjourn
18:00:12 <gholms> [You hear the sound of bubble wrap upstairs]
18:00:22 <woodyrollins> #endmeeting